Resolving ‘LEADS’ message on your pelvic floor exerciser

There are two main reasons why you may be getting the ‘LEADS’ message on your control unit:

1. Fault in the lead wires or probe connections

An intermittent break in the lead, or the short lead attached to the probe, could be the cause of your LEAD fault. You can purchase a replacement set of leads via the ‘Accessories’ page.

2. The probe being used is not the optimal shape for you

Peoples’ bodies vary. If there isn’t enough contact on the electrode plates the electric current cannot flow.

In this instance, you could try:

i)  Using a water-based lubricant gel such as Go Gel to improve the contact.
ii) Try using a different probe: The Liberty Plus is a larger probe which may provide better contact for some women.

"LEADS" Error Troubleshooting

No sensation and LEADS alarm showing.

Check lead and probe connection:

Dampen your hand with water and a little table salt. Squeeze the probe firmly in your hand and carefully increase the strength until you can feel something or LEADS alarm shows.
a) If you CANNOT feel anything, either the lead or the unit is faulty
b) If you CAN feel something on your hand, and the LEADS alarm does NOT show, then there is nothing wrong with the unit or lead.

The electrical conductivity of the vagina varies widely. The LEAD detection circuit in the product is there as a safety feature to ensure any rapid changes in connection cannot cause very uncomfortable, rapid changes in stimulation.

Unfortunately this means that some users may experience unwanted LEADS alarms.

If you experience unwanted LEADS alarm, please try the following:

i)  Use a water–based lubricant. This will improve conduction
ii) Purchase a larger probe: the Liberty Plus probe is 4mm wider than the standard Liberty probe
iii) Cross your legs and squeeze to increase pressure on the probe, which should improve the connection. If this enables you to use the unit, you should find that in a few weeks of stimulation the contact improves.

If none of the above solves your issue, then we are sorry to say that the unit will not work for you.

 

No sensation and no LEADS alarm
If you have tried the tests above and DO have sensation when the probe is in your hand, then you may have reduced sensitivity due to previously damaged or desensitized pudendal nerves (this can happen in childbirth or some surgical procedures).

In this instance, please contact your GP for advice.

 

No sensation on one side
The current flows from one side of the probe to other, so it is not possible to have one side which is “not working”.

However, the strength of the sensation depends on how close to the nerve the current flows and also in which direction it flows relative to the nerve.

You can try slightly adjusting the position of the probe, or exchanging the connection of the wires in the probe.

Please note that the leads for the newer iTouch Sure and Elise units have a new plastic connecting plug, and the leads for the older iTouch Sure and Elise units have a metal connecting plug.

IncontinencePelvic floorProduct supportTroubleshooting

Leave a comment

All comments are moderated before being published